在代码的日子里希望你我同行!

关于在MAC OSX 系统升级为 OSX EI Capitan (10.11.6) 之后cocoapods 的无法安装的问题

在MAC系统升级之后,cocoapods报错, 无法安装的问题!
和之前的安装并没有太大的区别 - 唯一的区别就是安装路径的命令
直接上解决办法!
安装步骤! (不要输入前面的 $)
1>打开终端,输入

$ sudo gem install cocoapods

输入密码
2>输入

$ gem source -l

查看源! 如果是http://rubygems.org
请移除:

$ gem sources --remove https://rubygems.org/

3>输入

$ gem sources -a https://ruby.taobao.org/

替换之前的第2>步
4>输入

$ gem sources -l 查询是否替换成功

5>输入

$ sudo gem install -n /usr/local/bin cocoapods

开始正式安装 PS:之前是

$ sudo gem install cocoapods

6>输入

$ pod setup

开始安装
关于在MAC OSX 系统升级为 OSX EI Capitan (10.11.6) 之后cocoapods 的无法安装的问题
7> 出现

Setup completed

为安装成功

关于cocoapods 如何正确的下载/安装/导入/使用-第三方库

已有 4 条评论
  1. RocioXRuma

    Hi! Where I can download the XRumer 12? This URL is not working - http://freecheapxrumer.com/ :(

    RocioXRuma 回复
  2. Oscarweend

    is very nice!

    Oscarweend 回复
  3. Charlesfieft

    how to download music from google play to pc

    Charlesfieft 回复
  4. DannyRznal

    Hello. And Bye.

    DannyRznal 回复
发表新评论